WC3 KS Version fix on XP

Mincemeat

Doomsday's Neighbour
*thinking out loud*

Speculation: If an application ever spawns more than one thread, it would get handled in the OS level differently depending on whether your system is truly uniprocessor or not.

Fact: Windows NT/2000/XP/2003 loads a different kernel if the system has more than one "processor" - that includes hyperthreading and dual core.

Speculation: Any differences like the above can become a source of otherwise inexplicible bugs...
 

Mincemeat

Doomsday's Neighbour
Mordrid said:
This is fantastic, keep up the great work!!

-Dj

Can you please elaborate on what system you have and what game(s) behaved differently with the patch? It would be nice to know what works and what doesn't.

Cheers :)
 

Master Katarn

Rear Admiral
In any case, I don't have a dual core system, just a 1.2 Ghz AMD processor. Privateer 2 is still crashing despite my trying various fixes with the Application Compatibility Toolkit. Still trying though...
 

Falcon988

Commodore
I would just like to make note that this fix for WC3 did not work for me at all. Although I'm not entirely sure I did it right, the Compatibility program is a bit odd for a newcomer. However, after I managed to get my screen to look like the screenshot in the first post and did a "Run program", WC3 did not work at all. Before the intro even began it locked up and stayed that way.

This is unfortunate for me because the keyboard input lag is a serious problem for me while playing. I hit afterburners and it's like the key sticks for a long time and I continue afterburning long after I've let go of Tab. Plus I can't maneuver while afterburning at all. I can't maneuver while flicking through the guns, or any ship function. I work around it but it'd be nice to play it perfectly.
 

Falcon988

Commodore
As an aside, I tried the superpatch to fix my new intro freeze problem. No luck there either. I'm very bummed out that WC3 has quit on me. It was just getting interesting dangit.
 
U

Unregistered

Guest
This Superpatch is great ! WC1 and Wc 2 works like a charm !! WC3 intro problem also is solved! But sometimes i get random crashes , its totaly random . When i hit "fly" button or when i want to talk with someone.
Im on windows xp
 
U

Unregistered

Guest
This is to everyone who has had problems using a joystick in KS: The reason it freaks out is because you're using USB-based hardware. When I try my Logitech Extreme Pro, the cursor flies into the corner while playing Wc1 and Wc2. You can fix this by using a joystick that starts as a serial, but has a USB adapter. For some reason, this fixes the problem, and I can play all old games on XP fine.
 

Mincemeat

Doomsday's Neighbour
Falcon988: What does KS WC3 run like on your computer before attempting any compatibility fixes? Also how well does WC2 run? Mine's terrible (Audio skip/repeat errors and random crashes) but playable.

By the way, I was using WinXP SP2. Am unsure if different Service Pack levels will affect results, I suspect it might...
 

Skanks

Rear Admiral
My KS WC3 was still crashing till I added LowerThreadPriority & SingleProcAffinity to the SDB. Anyone using this having a problem may want to try that.
 

Tarin

Spaceman
I'm sorry to say this isn't working for me. I tried Skanks' settings as well and nothing. The game still crashes after a while.
The only good thing is that while using Mincemeat's version, I am able to go back to windows when that happens and don't need to restart...

However that's not all that helpfull obviously... :(
 

Mav23

Swabbie
Banned
Well I guess I'll finally have to shell out for a Dos version of WC III on eBay. I've tried everything I've seen on this board and no dice. At least they don't seem to be going for too much right now. :)
 

NuAngel

Rear Admiral
Mine crashed because of a glitch in a music file (likely a finger print on the disc or something).

Once in the cockpit, I hit ALT+O and then turned off 'in-game-music' and it worked fine after that.

Nu
 

Mav23

Swabbie
Banned
Well I have yet to GET to a cockpit. God this sucks, mostly because my anal retentiveness won't allow me to play WC IV, Prophecy, or Secret Ops until I've beaten III again. :(
 
J

JJohn

Guest
Great job !!!

Mincemeat said:
Tell me what you think...
Attached Files
File Type: pdf MincemeatWCSuperpatch.pdf (3.3 KB, 107 views)
Works perfectly with WC3KS, the only way i've found to make WC3KS works on WinXp SP2.
A very great job Mincemeat
Thank you from France near Paris
++
PS1 : rename MincemeatWCSuperpatch.pdf as MincemeatWCSuperpatch.zip
PS2 : a moderator should make this post a sticky, it works really well
PS3 : sorry for my poor english
 

dacis2

Spaceman
Another happy user here. Mincemeat's patch thingy didn't work on its own though, but Skanks did the job. I have a similar system (XPSP2, 3.0GhZ processor with Hyperthreading).


By 'did the job', I mean 'I'm never going into the Berths without saving again!', cause that's the spot that crashes for me.

Gotta go do more extensive testing though
 
U

Unregistered

Guest
Mouse issue

Hey all,

I've tried everything I can think of here, so I need some help.

I'm trying to play WC1 (KS version) under XP. Game runs well through intro, smooth, right speed, sound. But when it get's to the start screen (start/continue vega campaign) my mouse tracks to the upper-left corner and won't budge. It's a Logitech Mx-510 USB.

Computer's a pIV 3.2, XP-Pro sp2. No joystick (always played with mouse back in my dandy-tandy days).

I've tried the superpatch: No luck.
uninstalled superpatch and tried win95 compatibility mode: No luck.

Anyone got any ideas??
 
U

Unregistered

Guest
Unregistered said:
Hey all,

I've tried everything I can think of here, so I need some help.

I'm trying to play WC1 (KS version) under XP. Game runs well through intro, smooth, right speed, sound. But when it get's to the start screen (start/continue vega campaign) my mouse tracks to the upper-left corner and won't budge. It's a Logitech Mx-510 USB.

Computer's a pIV 3.2, XP-Pro sp2. No joystick (always played with mouse back in my dandy-tandy days).

I've tried the superpatch: No luck.
uninstalled superpatch and tried win95 compatibility mode: No luck.

Anyone got any ideas??

PS: Same problem for WC2
 

AD

Finder of things, Doer of stuff
Unregistered said:
Hey all,

I've tried everything I can think of here, so I need some help.

I'm trying to play WC1 (KS version) under XP. Game runs well through intro, smooth, right speed, sound. But when it get's to the start screen (start/continue vega campaign) my mouse tracks to the upper-left corner and won't budge. It's a Logitech Mx-510 USB.

Computer's a pIV 3.2, XP-Pro sp2. No joystick (always played with mouse back in my dandy-tandy days).

I've tried the superpatch: No luck.
uninstalled superpatch and tried win95 compatibility mode: No luck.

Anyone got any ideas??

Even though you don't use it, do you happen to have a joystick or gamepad plugged in? It's possible the stick is stuck off center or not calibrated right and the movement is overriding your mouse. (I have the same mouse and have never had that problem, though I don't have KS but I use the dos version in dosbox)
 
Top