WC3 KS Version fix on XP

U

Unregistered

Guest
AD said:
Even though you don't use it, do you happen to have a joystick or gamepad plugged in? It's possible the stick is stuck off center or not calibrated right and the movement is overriding your mouse. (I have the same mouse and have never had that problem, though I don't have KS but I use the dos version in dosbox)

No, no joystick/gamepad. I downloaded the KS version figuring it'd be better able to be run under XP Pro....

I'm on an Old-Game kick currently (taking a break from X3/HL2 /Prey/F.E.A.R. etc

Go figure, my Quest for Glory (VGA), runs perfectly under dosbox. I think I'll try to download the dos versions and go that route, unless someone knows a fix for the KS version. I remeber it happening to me before when I had an old P2-266/win95 with some patch, but that was 10 years ago, and there's a lotta beer and frat parties between then and now....... ;)
 

AD

Finder of things, Doer of stuff
Unregistered said:
No, no joystick/gamepad. I downloaded the KS version figuring it'd be better able to be run under XP Pro....

I'm on an Old-Game kick currently (taking a break from X3/HL2 /Prey/F.E.A.R. etc

Go figure, my Quest for Glory (VGA), runs perfectly under dosbox. I think I'll try to download the dos versions and go that route, unless someone knows a fix for the KS version. I remeber it happening to me before when I had an old P2-266/win95 with some patch, but that was 10 years ago, and there's a lotta beer and frat parties between then and now....... ;)


Ehhh.... that's part of the problem. Kilrathi Saga is buggy as it is and the pirated versions add even more complications to the mix. Go buy the dos version for a few bucks on ebay. It will run better in dosbox than the Kilrathi Saga version will in xp.
 
U

Unregistered

Guest
So I'm guessing then that no one else has had this problem.....?
 

AD

Finder of things, Doer of stuff
Unregistered said:
So I'm guessing then that no one else has had this problem.....?

What's to say it isn't the broken version that you downloaded that is the problem? The thing is, we just can't troubleshoot pirated stuff here. Go buy a dos copy and I'm sure it won't be a problem to get it running in Dosbox.
 
U

Unregistered

Guest
I actually have a dos copy of this game (plus add-ons) and WCII (and the add-ons), got WC3 as well, along with WC4. WC4 is the only one that still works, becasue the CD's are in good condition. The disks for the other games have gone to crap after 9 moves since 1992 (family once, college 3 times, job 5 times.) So I already own them, so I don't consider re-aquiring a copy to be "stealing" anything. I bought the game, and the disks are crap, so I got another copy. And **please** don't hand me any crap about it. If they still were to remake the game for winXP, I'd shell out $49.95 for it in a heart beat, but they don't, so I can't, so I get a backup copy of it elsewhere.

Anyway, I found the issue, for some reason XP-Pro SP2 installed a game-pad driver of some type. I disabled it, and viola. So for anyone who happens to goole this issue and is reading this 6 months from now, do into your device manager, and ensure there's not a "HID-Compliant Game Controller" listed under your Human Interface Devices catagory. If there is, disable it and things should work fine.

Now if only I could find someone who's selling a Dos copy of X-wing (and the add-on's) so I could use the old editors.....
 

AD

Finder of things, Doer of stuff
Unregistered said:
I actually have a dos copy of this game (plus add-ons) and WCII (and the add-ons), got WC3 as well, along with WC4. WC4 is the only one that still works, becasue the CD's are in good condition. The disks for the other games have gone to crap after 9 moves since 1992 (family once, college 3 times, job 5 times.) So I already own them, so I don't consider re-aquiring a copy to be "stealing" anything. I bought the game, and the disks are crap, so I got another copy. And **please** don't hand me any crap about it. If they still were to remake the game for winXP, I'd shell out $49.95 for it in a heart beat, but they don't, so I can't, so I get a backup copy of it elsewhere.

The issue isn't with how *you* got it, though that is frowned upon. THe CIC can *NOT* in anyway ever be seen as endorsing or condoning so-called "abandonware" sites. NONE of the WC games are abandonware (as demonstrated by the upcomming EA replay PSP collection) and EA actively prosecutes "abandonware" sites that host WC1. THe main reason the CIC can freely have all the fan stuff is that they CIC respects this.
While we asked what version you had, we don't care and don't want to know where or how you got it. The CIC's stance on warez and such is reflected in the forum rules even:
11) Linking to, offering, requesting or hinting at the whereabouts of warez, abandonwarez, copying games or other illegal content can result in immediate banning.
 

Mincemeat

Doomsday's Neighbour
Very succinctly said, AD.

If one ever thinks that this policy is too harsh, remember that it is always better to err on the side of caution.

I won't be surprised if lawyers on IP enforcement are being paid on a bounty system, hence the trigger-happiness against even the most minor things taken completely out of context.

Hmm, I digress... but anyway.

Just something to bring the thread back on topic - I think I'll include Skanks' compatability changes (for WC3 only) into the next version and call it a day. Especially when all this seems so hit-and-miss and dependent on hardware/OS combinations anyway, the less fiddling the better :D
 
U

Unregistered

Guest
Wc2

hmmm i have sound and everything and i applied the superpatch... but i dont have any video... any suggestions?
 

AD

Finder of things, Doer of stuff
Unregistered said:
hmmm i have sound and everything and i applied the superpatch... but i dont have any video... any suggestions?


This is the Kilrathi saga version? You don't have video at all? Are you using an LCD?
 
U

Unregistered

Guest
Hi. The superpatch worked great with wc1 and wc2 saga but done nothing for wc3. The thing is, although i get skipping videos (which i can take), it randomly crashes. How do I add settings to the .sdb?
 
U

Unregistered

Guest
The workaround given by Skanks worked great. Thank you
 
U

Unregistered

Guest
AD said:
This is the Kilrathi saga version? You don't have video at all? Are you using an LCD?

yes the kilrathi saga version... wc1 loads up showing the sabres and broadswords and what not in the video... but once i get to the main screen i have nothing but sound (and yes i am using a flatscreen LCD i belive)... wc2 same thing i have perfect sound but no picture on the main screen, and i have the same problem after the intro video with wc3... thnaks for responding so fast any help would be appreciated :)
 

AD

Finder of things, Doer of stuff
Unregistered said:
yes the kilrathi saga version... wc1 loads up showing the sabres and broadswords and what not in the video... but once i get to the main screen i have nothing but sound (and yes i am using a flatscreen LCD i belive)... wc2 same thing i have perfect sound but no picture on the main screen, and i have the same problem after the intro video with wc3... thnaks for responding so fast any help would be appreciated :)


The problem might be your monitor. The game might be trying to switch to a mode unsupported by the LCD. There may be a way to force the game or the monitor into a resolution that works. I can't remember if there is an option to play wc1 or 2 windowed with KS. Try hitting alt-enter to get it into a window. Alternatly you may need to adjust the controls on the monitor itself to force a different resolution. I'll search the forum (this has come up before) and see what I find.
 

Mincemeat

Doomsday's Neighbour
Here is an updated version of the patch, which includes Skanks' fixes for WC3. Enjoy!

(As usual, rename .pdf to .zip, or until an admin places a direct download link :D)
 

Attachments

  • mincemeat_wc_superpatch.pdf
    3.5 KB · Views: 971

Killer

Rear Admiral
I definitely would say the patch is fantastic for keyboard issues as well as random crashes. I myself though am still having the problem where the game will occasionally completely freeze after playing a movie scene (a transition, a briefing, a cutscene). Disabling transitions and pressing escape just before a screne completes (for example Rachel's comments after landing) works well enough... But the ultimate goal is a complete fix. I'd guess its an issue with the way the xan movie player interacts with modern directx... and while its possible to workaround with minimal impact... it does detract from the experience
 

Killer

Rear Admiral
I wonder. Because most of the issues with WC3 KS under XP do seem to be related to the playing of cutscenes, has anyone (with more programing know-how than I, obviously) tried to decompile the xanlib.dll and try to figure out why its doing what its doing? The more I think about the issue, the more it seems likely the library file is the culprit
 
U

Unregistered

Guest
My WC3 works really weirdly. first, none of the patches worked better or worse. my game actually runs, and well. that is, if i dont esc cancel a movie. if i do, the very next time i click on a new area to move to or click someone to talk, the game freezes.

this means every "getting into the cockpit" movie or "getting on the elevator" movie i have to watch or i crash.
 

cff

Kilk'dymga'qith laq Ik'vikvi
You can at least disable the movies that connect rooms together (like the elevator) from the menu if you want to bypass them permanently.
 

AD

Finder of things, Doer of stuff
Unregistered said:
My WC3 works really weirdly. first, none of the patches worked better or worse. my game actually runs, and well. that is, if i dont esc cancel a movie. if i do, the very next time i click on a new area to move to or click someone to talk, the game freezes.

this means every "getting into the cockpit" movie or "getting on the elevator" movie i have to watch or i crash.

Is this the Kilrathi saga version? Are you running winXP? you need to be more specific in these cases. If that is the case, *do not* use any of the patches. I think there is one for win2000 but it is not for XP and will create other problems. If you have, reinstall fresh (which in it self could solve things if there was an install error the first time). There are some bugs inherent in the KS version, but have you aplied the compatability modes? Try both win95 and 98. Does adjusting the level of hardware acceleration in windows (for sound possibly) help at all? If you haven't already these are worth a shot.
 
Top