WC4 Mod For Homeworld 2 In The Works (June 5, 2006)

TonViper

Rear Admiral
Having problems getting my UV map to play ball with the HW2 editor, I went back to basics and took some more screenshots of the mod. The new shaders just got an upgrade and look even more impressive than before.

You really have to see them in action to get the full effect though. If the mod is properly integrated with the shaders, energy shots light up the ships as they pass close by. :D

Also, since the AI doesn't work in the mod, I've reactivated the Hiigaran and Vaygr sides temporarily. To get some combat going, those shots are of a fight, Confed vs. Vaygr. I've tried keeping the Vaygr out of frame, so that isn't readily apparent.
 

Attachments

  • ss00005.jpg
    ss00005.jpg
    148.5 KB · Views: 242
  • ss00006.jpg
    ss00006.jpg
    318.2 KB · Views: 310
  • ss00008.jpg
    ss00008.jpg
    237.6 KB · Views: 230
  • ss00009.jpg
    ss00009.jpg
    128.4 KB · Views: 229
  • ss00010.jpg
    ss00010.jpg
    188.7 KB · Views: 261

TonViper

Rear Admiral
Got the AI working, so now I can get some proper action screenshots.

Still need to get it to research stuff, so for now it's barred from the more advanced tactics. Gonna have to see if I can convince it to build more than one carrier too.
 

Attachments

  • ss00015.jpg
    ss00015.jpg
    267.2 KB · Views: 171
  • ss00014.jpg
    ss00014.jpg
    334.7 KB · Views: 203
  • ss00013.jpg
    ss00013.jpg
    322.7 KB · Views: 237
  • ss00012.jpg
    ss00012.jpg
    276.2 KB · Views: 177
  • ss00011.jpg
    ss00011.jpg
    213.6 KB · Views: 198

TonViper

Rear Admiral
Screenshot spam. Hope you don't mind. ;)
 

Attachments

  • ss00020.jpg
    ss00020.jpg
    180.3 KB · Views: 180
  • ss00019.jpg
    ss00019.jpg
    464.2 KB · Views: 205
  • ss00018.jpg
    ss00018.jpg
    499.4 KB · Views: 236
  • ss00017.jpg
    ss00017.jpg
    489 KB · Views: 234
  • ss00016.jpg
    ss00016.jpg
    406 KB · Views: 300

TonViper

Rear Admiral
Last batch for now.
 

Attachments

  • ss00021.jpg
    ss00021.jpg
    405.5 KB · Views: 205
  • ss00022.jpg
    ss00022.jpg
    433.1 KB · Views: 201
  • ss00023.jpg
    ss00023.jpg
    419.5 KB · Views: 193
  • ss00024.jpg
    ss00024.jpg
    122.1 KB · Views: 168
  • ss00025.jpg
    ss00025.jpg
    250.5 KB · Views: 185

GreyViper

Rear Admiral
Wow just wow what new shaders can do to a game. Compare them with the page 1 and they feel like different game. TonViper hope you get it working smoothly since that would reinvigorate this mod a lot.
 

TonViper

Rear Admiral
Managed to get the HW2 editor working, so here's a test shot of my Excalibur model ingame. It is by no means done yet. The texture is only halfway done, I haven't done the specular map yet, and I still haven't figured out how to give it a bump-map without crashing the game.
 

Attachments

  • ss00026.jpg
    ss00026.jpg
    309.6 KB · Views: 283

czacen

Spaceman
WOW! just WOW! amazing stuff tonviper. thanks for holding down the fort while i was gone. it completely floored me to see the mod on the front page again :). I think however we should adjust the strategy here. since i was anyways revamping ships for the existing mod, what you say we join forces and revamp the existing mod to all its glory. The new concordia will look much better with those new shaders. what do you think? i can pass you the newer high res - more accurate models - and you can do the texturing and shaders and we can start on V2 of the mod. PM me to talk this over more. Also ive been working on an excal myself but thats more for the cinematic intro. Id love to help with your modeling process any ways i can, this way we can really bump the mod to a whole new level. BTW i noticed that you are working with a much older version of the mod, the AI and stuff got sorted out in the newer version. PM me if you are interested we can talk this over. Excellent work! Im very excited abt this. :D
 

matthew954

Spaceman
Ok, guys I finally got a replacement copy of Homeworld 2, and downloaded the mod. However, I can't get it to work. I copied the target and starting location boxes of the original Homeworld Shortcut, but with the wc4 mod listed at the end. Well when I click on the new shortcut it gives me an error:

Conflict with disc emulator software detected. See www.securom.com/emulation for more details

Anyone who can give me a hand in getting the mod to work, I'd appreciate it.
 

matthew954

Spaceman
Well I found out part of the problem. The game didn't like the fact that I used the official 1.1 patch. It plays just fine before its patched, but I get that error after its patched. I never had the problem with the patch on the old copy I have.
 

TonViper

Rear Admiral
Actually the patch isn't the problem. Most mods require the patch to work so it's only a stopgap measure you've got there.

The real solution is to run the game in windows NT compatibility mode. That takes care of it.
 

TonViper

Rear Admiral
Just wanted to let everyone know that I haven't really looked at this since czacen posted last. I PM'ed him about it but never got a reply. I've been working full time in the mean time, so I haven't had time for much anyway, but once he rears his head in here again, I'm ready to assist the mod.
 

Dundradal

Frog Blast the Vent Core!
Did you try PM or emailing him? He seemed devoted to this project, so he might just need a reminder.
 

TonViper

Rear Admiral
Like I wrote in my last post, I did pm him about it back when he asked me to. I never got a reply. It's like he fell off the face of the internet.
 

Luwinkle

Spaceman
Holy thread necro, Batman.

So I just tried to install this mod..the path given in the Readme was incorrect..clicking the shortcut had me browsing for the .exe.
I found it but then I get an error about gslobby.dll not being found.
Any way to fix this?
I've been looking at old WC screenshots and videos for the past couple of hours and I'm having SEVERE nostalgia overload.

And I looked at czacen's profile..his last activity was Feb 1 2009.

EDIT: And while I'm at it..anyone know how to get HW2 to run in 1680x1050? Or any 16:10 ratio?
 

TonViper

Rear Admiral
*comes in from the left wing completely out of nowhere*

Hi there all. Turns out that when czacen was logged in last, he left me a pm about the status of the mod. Problem is that since I last posted in the thread I've only kept up without logging in so I didn't read the message before today.

It seems that the perils of real life has claimed another victim in the form of czacens spare time. He's informed me that he hasn't had time to do anything with the mod lately and don't know when he'll be able to do so again.

The mod isn't dead, though it is on an extended hiatus until czacen finds time and inspiration to work on it again.

Until then we can only wish him well and hope that things calm down for him so that he may return to the world of modding.

I myself have also had to prioritize my spare time and haven't much time for modding. I've also had to put my little side project of implementing the new shaders in the mod on hold, since I'm already on two other mod teams besides working a full time job, developing a web page alongside that, and getting ready to move to a new apartment soon.

Anyway, I'll be watching this thread for when czacen comes back

-----------------------------------------------------------------

And now for a constructive comment for Luwinkle:

To get the game to run in any resolution you want, just add these switches to the game shortcut: -w 1680 -h 1050

Of course, just substitute the numbers for whatever resolution you want. I'm playing in 1920x1200 myself.

-----------------------------------------------------------------

As for troubleshooting your mod installation, how did you install it?

I'd recommend placing all the mod folders in an empty folder and then manually moving them to the right place in the game folder.

I can't remember the form of the last release of the mod, so I can't give you step by step instructions.

Post which files/folders you have in the mod and I'll tell you how to get it working.
 
Top