WC4 GOG Video

LividLiquid

Rear Admiral
I broke down and bought WC3 and 4 on GOG because of the sale over the weekend, and because I heard that the WC4 replaced the Disc version's compressed-to-hell video with DVD Quality video.

Did I install the wrong codecs or something? The framerate on the video is WAY too high. It no longer looks like it was shot on film. It looks like old British television, or when you use predictive frames (TRUmotion or whatever brand name your television uses) on a a newer wide-screen. Is this normal? It's awful!
 

AD

Finder of things, Doer of stuff
I'm not sure what you mean... It's a fixed framerate. It's possible it's a codec setting but without seeing what you're talking about I can't tell you for sure. It is encoded 4:3 though so if you have a widescreen monitor the patch will be doing a "touch window on outside" type zoom so that it fills your monitor correctly. I can't say the DVD was the best encoding but it's still much clearer than the CD version.
 

LividLiquid

Rear Admiral
Also, I do have a widescreen monitor like you said. Is there any way I can make the movies run in their normal aspect ratio?
 

AD

Finder of things, Doer of stuff
Also, I do have a widescreen monitor like you said. Is there any way I can make the movies run in their normal aspect ratio?
The aspect ratio is correct... It's just zoomed so you don't get the pillar boxing. Still, you could try running it in directx mode instead of opengl... that might help. If you download this patch and unzip it into your WC4DVD directory https://www.wcnews.com/chatzone/attachments/dwrap-1-0-1-test4-zip.5618/ you will have the option of using a couple of different render modes other than the default openGL.

- ddraw, which uses Direct Draw for rendering. Does not support a good deal of features provided by OpenGL mode (pillarboxing and video adjusting for widescreen mode, etc), although it should still fix the palette issue in Win7 (which is not really an issue for you anyway, since you use XP).

- legacy, which forwards the game's DirectX calls to real DirectX, bypassing our DirectX wrapper completely.

you can choose your renderer by placing "opengl", "ddraw" or "legacy" in renderer.cfg
 
Last edited by a moderator:

Dudemanjac

Spaceman
I have a similar issue with WC3 The video is very grainy. It's almost like it is all playing at a lower resolution
 

AD

Finder of things, Doer of stuff
I have a similar issue with WC3 The video is very grainy. It's almost like it is all playing at a lower resolution

WC3 is older and doesn't have DVD quality video. Plus the compression used in the PC version has a wierd sticky pixel issue. It's going to look grainy because of the blockyness of the pixels. You could try running dosbox with upscaling and a smoothing filter.
 

AdamPH

Petty Officer
The aspect ratio is correct... It's just zoomed so you don't get the pillar boxing. Still, you could try running it in directx mode instead of opengl... that might help. If you download this patch and unzip it into your WC4DVD directory https://www.wcnews.com/chatzone/attachments/dwrap-1-0-1-test4-zip.5618/ you will have the option of using a couple of different render modes other than the default openGL.

I tried ddraw, but it seems the one that does the 4:3 as I also wanted makes the space combat a black screen. Whoops! legacy seems to work. ;) I'll mess around more and give an update.
 
Last edited by a moderator:
Top